AvMap G5

Moderator: Global Moderator Team

User avatar
K4NNW
142490-000000-7
Posts: 389
Joined: Wed May 16, 2007 9:14 pm
Location: That depends...
Contact:

AvMap G5

Postby K4NNW » Tue Nov 25, 2008 1:47 pm

Well, I went against my gut instincts and bought an AvMap G5 this summer for the truck (and for APRS with my D7). It does ok for APRS, but the only icons that it'll spit out in NMEA mode are a circle and a triangle, for moving and fixed stations, respectively (maybe I have this backwards, but since the unit's not working now, I can't just turn it on to check).
The sensitivity isn't all that great, compared to my Garmin 276. It does ok at acquiring while suction-cupped to the windshield. Surprisingly, that suction-cup mount has held right firmly in both the Freightliner Classic I used to drive and the Freightliner Century that I drive now.
The user interface isn't bad, and it's easy to use while driving.
I don't like the fact that it uses a funky, four-conductor jack for data in/out that does NOT provide a provision to externally power it. Instead, an external coaxial power jack is provided, as is a cigarette lighter cable (which appears to be natural rubber, rather than the kinda stuff used on most wiring).
This thing uses TeleAtlas maps. They suck... Why? Because not only are some little county highways missing, but some major highways are just not there in the GPS (like I85 BR in Greensboro, NC). I73 and I74 in NC were also right flakey, but I think they got fixed recently.
Due to these mapping shenanigans, one usually needs to download the latest firmware installer from their website, then run it, and update the firmware. One must also back up all their 'contacts' (as AvMap calls their waypoints) unless you want them gone.
While all this was annoying, it didn't prepare me for what happened on a routine trip. I told the G5 to navigate back to the distribution center (to see how many more miles I had before I arrived). It gave me a couple error messages, and then I noticed that it kept telling me I was off-road, which I wasn't. I was on US highways the whole time. Ooops. Eventually, I got home and tried a firmware update. After trying to reformat the SD card where maps are, I found that I couldn't write files to the card (yet could delete them) and now the GPS is a brick. AvMap did say that they'd send a new card out, so I'll hopefully have it by the end of the week.
It seems like they have decent customer service (better than most companies I've dealt with), but the product isn't all that great.
Oh, and get this... This GPS is made in... ITALY! Yes, I was surprised, too.
Make of it what y'all will.
"My favorite version of selective inhibit is that which you use upon both the radio and operator... in the form of a tire iron." vxo
"Ever seen a chick in a skirt, working on a 50 KW Harris transmitter? Yeah, I'll admit it, I've done it." K2KLI
"I think God is telling me to buy Ford. I ain't listening." motorola_otaku

Return to “EQUIPMENT REVIEWS”

Who is online

Users browsing this forum: No registered users and 4 guests